Need help

May 25, 2011 at 11:42 AM

Hi i've use you exemple code and changed the location of files and folder but when i try to generate a map it say :

 

Loading world...
Unhandled exception:

System.InvalidOperationException: The world format is not supported.   
at Terraria.World..ctor(String path)   
at TerrariaMapTool.MapGenerator.Generate()   
at TerrariaMapTool.Program.Main(String[] args)

This is really a nice Map generator if you could help me out i would appreciate 

Coordinator
May 25, 2011 at 4:51 PM

There could be one of two reasons you are getting this:

First, I wrote this before the 1.0.2 patch and have been running it against a world created before this patch. It is possible that the format changed with the new update and worlds created after the update may not work.

The second reason would be that you're running a map that was generated from the alpha version. The generator can only support worlds created by the released steam version.

 

If you could share your world file somewhere for download I could try to run it tonight and reproduce the issue. That's the quickest way to see what is wrong. (Also suggest a new todo, print out to world info when the tool starts up. I'll definitely add that at least tonight.)

May 25, 2011 at 6:37 PM

Heya!

I think it's 'first' - this generates a map fine on a world I created pre-1.0.2, but not for any of the worlds I've created post-1.0.2. Do you have an plans for updating this to work with the most recent patch? :)

Coordinator
May 25, 2011 at 7:39 PM

I'll create a new world tonight and figure out what the hiccup is. Shouldn't be to difficult to fix.

May 25, 2011 at 7:42 PM

Awesome! Much love :D

I've made a tutorial video showing people how to use this - should drive some traffic here and get you some downloads. :)

 http://www.youtube.com/watch?v=Ki85TpI0FNo 

Coordinator
May 25, 2011 at 7:57 PM

Much appreciated. I find the documentation part the tedious aspect of these projects. ;) Maybe I'll get around to created a GUI. At the very least generate the stub html file for people.

May 26, 2011 at 1:24 AM

I'm on the latest version of Terraria didn't play before the last update so ma maps are all after patch 1.0.2

so i guess that is my problem .. and i'll wait for a update but , it looks like a great map gen , better from all of the other from what i

Coordinator
May 26, 2011 at 2:23 AM

Just uploaded a new version that should fix it. Give it a try.

May 26, 2011 at 8:44 AM

It works! Yaaaay! Thank you ^.^