"map generator has stopped working"

Jul 12, 2011 at 6:49 PM

When I try and run the tool I get a standard windows 7 error message telling me that terraria map generator has stopped working when it is 2 seconds into generating a map. I have tried it on compatibility mode but that didn't fix it. 

Jul 22, 2011 at 7:36 PM

i have thesame issue

Jul 22, 2011 at 7:56 PM

it gives me the same message at 10 seconds into it, and it used to work but now it frikken wont wtf. I tryed running it as admin, i tryed reinstalling it. nothing works.

Jul 23, 2011 at 3:27 PM

I too am having a similar issue, the generator had been working fine for me all week, but today for some reason, it will no longer work with the world I am currently using, but if I drop an older world into it, it will generate fine. Could there be something wrong in the world?

Coordinator
Jul 24, 2011 at 8:16 AM

If you could post the world I could attempt to run it myself and see what is going wrong.

Coordinator
Jul 24, 2011 at 8:49 AM

A new version 1.0.0.6 has been uploaded. Give that a try.

Jul 24, 2011 at 9:18 AM
Edited Jul 24, 2011 at 9:21 AM

I just did an initial run via command line (gleaned from the readme/tutorial), but it ended up creating something that was just black when loaded in Chrome.
Edit: Nevermind, I think I flubbed the command line... doing it in GUI now to get it right.

Is there a parallelize generation option for command line? 

Coordinator
Jul 24, 2011 at 9:39 AM

Nope. I need to update the argument parser to enable that. Easy change though. I'll get to it in the next day or so.

Jul 24, 2011 at 9:56 AM

I don't suppose you have any desire to create a Linux version of this? I'm guessing it is much harder than it sounds, but that'd be pretty spiffy. It makes me sad that the dedicated Terraria server is windows only, but at least it is low CPU usage. Scheduling this to run every few hours on my Windows computer makes me sad :(

Jul 24, 2011 at 11:28 AM

Is the output not meant to be viewed via a web server? I can load this fine in Chrome via file browsing, but not from my own domain.

Coordinator
Jul 24, 2011 at 10:05 PM

1) As for a linux version, the program is dependent on XNA in order to access the game assets for drawing the tiles. As far as I know, Mono is workingon supporting XNA but it is not there yet so attempting to run this program on linux won't work at the moment. Other options of reimplementing this completely as a cross platform C++ program would require reverse engineering the xnb format and this being just a pet project I don't have the time to devote to such an endeavor.

2) There is no reason the output cannot be view through a web server. I had an example of this hosted on an IIS server but there is nothing blocking it. You may need to tweak the Map.html file and update the basePath to correctly point to your domain. Also you need to insure that the image folders are publically visiable.

Jul 24, 2011 at 10:29 PM

After viewing the Map.html, it became pretty obvious what the problem was. It works great served from a web server, for example http://fryfrog.com/terraria/. I'm playing around with layers now, so it is not working quite right yet.

Do you have some preferred setup? My first render was with everything as a single layer. Right now, I'm generating each item as its own layer... but I think that might be over kill. It seems like 3 layers might be the best compromise? One for background and water, another for resources and the third for pots, hearts and chests.

Jul 25, 2011 at 10:20 AM

i just tried the new version and it seems to be behaving exactly the same and windows isn't giving me any feedback on why it stopped working

Jul 25, 2011 at 6:15 PM

@karkarn, fwiw it is working for me. Have you considered running it as a cmd line instance to see any actual errors? And are you sure you updated everything?

Coordinator
Jul 26, 2011 at 1:16 AM

The easiest way to fix the issue would be for you to upload your world file. Aside from that I can't debug it.

Jul 26, 2011 at 10:04 AM

I'm probably showing my lack of capability with computers but how would I run it as a command line instance?

Jul 26, 2011 at 3:48 PM
Edited Jul 26, 2011 at 6:12 PM

You're probably better off doing as the author suggests and uploading your world file.

The directions for running it via command line are on the Documentation page, it isn't very difficult except that the command itself is pretty long.

 

As an example, this is what I run: C:\Users\fryfrog>cmd /c c:\Games\Steam\steamapps\common\terraria\terrariamaptool.exe -terraria "c:\Games\Steam\steamapps\common\terraria" -world "C:\Users\fryfrog\Documents\My Games\Terraria\Worlds\world2.wld" -output "W:\fryfrog.com\htdocs\terraria" -blocksize 16,16 -layer drawwalls,drawbackground,drawbackgroundwater,drawforegroundwater,drawbackgroundtiles,drawforegroundtiles -zoomlevels 0.03125,0.0625,0.125,0.25,0.5,1 -mapdata

But of course you'll have to adjust some of these paths to work for yourself, especially the output directory.

Jul 27, 2011 at 10:56 AM

Hmm so how would i go about uploading a map?

Coordinator
Jul 29, 2011 at 7:09 AM

You can use a site like mega upload to host the file then I can grab it and figure out why it's borked.

Jul 29, 2011 at 10:10 AM

What details of my megauploader account do you need?

Aug 12, 2011 at 6:55 AM

I have also had the same issue as the people above.  It works on my two older maps, but my current map stops at 7 seconds in, still saying it's loading the map, and crashes.

 

Here is my world .wld file:  http://www.megaupload.com/?d=BJHFYRQY

And here is the .wld.bak file:  http://www.megaupload.com/?d=R4WWBPF5

 

Let me know if you need any more infoz!

Aug 12, 2011 at 5:48 PM

Same here. Before it worked quite fine but now its not. Is it maybe because of the new world update? 

Aug 12, 2011 at 6:38 PM

It is because of the update. Hoping that rpowers3 will update the tool to work with the current version of Terraria

Aug 14, 2011 at 3:08 AM

Here here, I absolutely love this application, unfortunately I haven't been able to use it yet due to having both updated world files and Terraria Client. I run a successful Terraria server, and having this complete with command line access would be fantastic! Please please update it to work with the new version :).

Coordinator
Aug 16, 2011 at 2:19 AM

I'm working on a fix now that will hopefully sure this up for future patches.

Aug 16, 2011 at 3:28 PM

Nice, looking forward to that :-)

Aug 17, 2011 at 10:02 PM

Terraria version 1.0.6.1 has just been release on Steam.

Coordinator
Aug 18, 2011 at 4:01 AM

Yep, saw it. Almost done with the next version. Should be out tomorrow or Friday.